BarycenterHelper is missing from v1.2 but is referenced in most Kinect Toolbox code samples found on the Internet

Jan 1, 2013 at 4:00 PM
Edited Jan 1, 2013 at 4:01 PM

Many sample projects on the internet use the Kinect Toolbox dlls and call upon the "BarycenterHelper" class. BarycenterHelper is mentioned on the Kinect Toolbox main page. However it looks like this class is only available up to the old v1.1.1.0 library. v1.2 doesn't have BarycenterHelper. Is there tutorial on how to convert sample code that uses BarycenterHelper to a new v1.2 supported class?

TIA

Jan 1, 2013 at 9:16 PM

If anyone else has this problem, the solution is to replace BarycenterHelper with the new v1.2 class ContextTracker.

Thanks

Mar 8, 2013 at 11:04 AM
Thanks a lot. I had this problem today, and I luckily found this discussion. Thank you for your solution.
Apr 19, 2013 at 10:33 AM
May i use the kinect toolbox in sdk 1.6?
Apr 19, 2013 at 10:52 AM
Of crouse you can. I used it in SDK 1.7.